Resolved
Thanks for bearing with us as we fixed this.
All orders should appear on 'Orders' pages as usual. The order information that was delayed now appears in your Box Office.
Investigating
We are investigating reports that some recent order information is not appearing in the Event Organiser dashboard after people have bought tickets.
We know how important it is to have your order data at your fingertips and we are treating this as a priority.